<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>Anderson .Paak: Ventura - WPGU 107.1</title>

<!-- This site is optimized with the Yoast SEO plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://wpgu.com/anderson-paak-ventura/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Anderson .Paak: Ventura - WPGU 107.1" />
<meta property="og:description" content="Anderson .Paak had a busy 2018. Not only did he record his long-anticipated, third studio album, “Oxnard,” but also recorded &hellip;" />
<meta property="og:url" content="http://wpgu.com/anderson-paak-ventura/" />
<meta property="og:site_name" content="WPGU 107.1" />
<meta property="article:tag" content="Anderson Paak" />
<meta property="article:section" content="Album Reviews" />
<meta property="article:published_time" content="2019-04-18T16:33:30+00:00" />
<meta property="article:modified_time" content="2019-04-18T16:33:32+00:00" />
<meta property="og:updated_time" content="2019-04-18T16:33:32+00:00" />
<meta property="og:image" content="http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover.png" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="952" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Anderson .Paak had a busy 2018. Not only did he record his long-anticipated, third studio album, “Oxnard,” but also recorded &hellip;" />
<meta name="twitter:title" content="Anderson .Paak: Ventura - WPGU 107.1" />
<meta name="twitter:image" content="http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover.png" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Feed" href="http://wpgu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Comments Feed" href="http://wpgu.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.4.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.4.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1348014-23';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1348014-23', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wpgu.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='http://wpgu.com/wp-includes/css/dist/block-library/style.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='http://wpgu.com/wp-includes/css/dist/block-library/theme.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu%3A400%2C500%2C700%7CLato%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C400italic%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://wpgu.com/wp-content/plugins/employee-spotlight/assets/ext/font-awesome-4.7.0/css/font-awesome.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-style-css'  href='http://wpgu.com/wp-content/themes/hitmag/style.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-flexslider-css'  href='http://wpgu.com/wp-content/themes/hitmag/css/flexslider.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='screen' />
<link rel='stylesheet' id='jquery-magnific-popup-css'  href='http://wpgu.com/wp-content/themes/hitmag/css/magnific-popup.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"http:\/\/wpgu.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wpgu.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.4.2'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/html5shiv.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://wpgu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wpgu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wpgu.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://wpgu.com/?p=62694' />
<link rel="alternate" type="application/json+oembed" href="http://wpgu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwpgu.com%2Fanderson-paak-ventura%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wpgu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwpgu.com%2Fanderson-paak-ventura%2F&#038;format=xml" />
<meta name="generator" content="Employee Spotlight v4.6.0 - https://emdplugins.com" />
          <style>
          .has-post-thumbnail img.wp-post-image, 
          .attachment-twentyseventeen-featured-image.wp-post-image { display: none !important; }          
          </style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//wpgu.com/?wordfence_lh=1&hid=29B01A9DCB8A67BDCDDDB194A464CCC9');
</script>		<style type="text/css">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</style>
		<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}
			
			
		</style>
	<link rel="icon" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01-125x125.png" sizes="32x32" />
<link rel="icon" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" />
<meta name="msapplication-TileImage" content="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" />
</head>

<body class="post-template-default single single-post postid-62694 single-format-standard wp-custom-logo group-blog th-right-sidebar">

<div id="page" class="site hitmag-wrapper">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		
		
		<div class="header-main-area">
			<div class="hm-container">
			<div class="site-branding">
				<div class="site-branding-content">
					<div class="hm-logo">
						<a href="http://wpgu.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="240" height="80" src="http://wpgu.com/wp-content/uploads/2018/12/hireswpgu2.png" class="custom-logo" alt="WPGU 107.1" itemprop="logo" /></a>					</div><!-- .hm-logo -->

					<div class="hm-site-title">
													<p class="site-title"><a href="http://wpgu.com/" rel="home">WPGU 107.1</a></p>
													<p class="site-description">Champaign&#039;s Alternative</p>
											</div><!-- .hm-site-title -->
				</div><!-- .site-branding-content -->
			</div><!-- .site-branding -->

			<div class="hm-header-sidebar"><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="70082"></broadstreet-zone>
</div></aside></div>			</div><!-- .hm-container -->
		</div><!-- .header-main-area -->

		
		<div class="hm-nav-container">
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="hm-container">
					<div class="menu-top-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-33039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-33039"><a href="http://wpgu.com/about-us/">About</a>
<ul class="sub-menu">
	<li id="menu-item-33159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33159"><a href="http://wpgu.com/staff/">Directors</a></li>
	<li id="menu-item-61971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61971"><a href="http://wpgu.com/on-air-personalities-2/">On-air personalities</a></li>
	<li id="menu-item-60878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60878"><a href="http://wpgu.com/web-writers/">Web writers</a></li>
	<li id="menu-item-45859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45859"><a href="http://wpgu.com/music-submission/">Music Submission</a></li>
	<li id="menu-item-54799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54799"><a href="http://wpgu.com/contact-wpgu/">Contact us / support</a></li>
	<li id="menu-item-58717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58717"><a href="http://wpgu.com/apply/">Internships</a></li>
</ul>
</li>
<li id="menu-item-59827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59827"><a href="http://wpgu.com/category/on-air/">On-Air</a>
<ul class="sub-menu">
	<li id="menu-item-59640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59640"><a href="http://wpgu.com/category/can-i-kick-it-podcast/">CAN I KICK IT &#8211; PODCAST</a></li>
	<li id="menu-item-62123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62123"><a href="http://wpgu.com/category/writers-block/">Writer&#8217;s Block</a></li>
	<li id="menu-item-60794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60794"><a href="http://wpgu.com/category/loud-local/">Loud and Local</a></li>
	<li id="menu-item-61512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61512"><a href="http://wpgu.com/category/request-live/">Request Live</a></li>
	<li id="menu-item-61894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61894"><a href="http://wpgu.com/category/flashback-cafe/">Flashback Cafe</a></li>
	<li id="menu-item-61481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61481"><a href="http://wpgu.com/category/rollin-illini/">Rollin&#8217; Illini</a></li>
	<li id="menu-item-61895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61895"><a href="http://wpgu.com/category/illini-drive/">Illini Drive</a></li>
	<li id="menu-item-60795" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60795"><a href="http://wpgu.com/category/take-it-away/">Take It Away</a></li>
	<li id="menu-item-59828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59828"><a href="http://wpgu.com/category/music/interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-33162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-33162"><a href="http://wpgu.com/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-41883" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-41883"><a href="http://wpgu.com/category/music/album-reviews/">Album Reviews</a></li>
	<li id="menu-item-59847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59847"><a href="http://wpgu.com/category/music/music-news/">Music News</a></li>
	<li id="menu-item-59848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59848"><a href="http://wpgu.com/category/shows/previews/">Concert Previews</a></li>
	<li id="menu-item-59846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59846"><a href="http://wpgu.com/category/shows/concertreviews/">Concert Reviews</a></li>
</ul>
</li>
<li id="menu-item-54800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-54800"><a href="#">Social</a>
<ul class="sub-menu">
	<li id="menu-item-54802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54802"><a href="https://www.instagram.com/wpguillini/">Instagram</a></li>
	<li id="menu-item-54801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54801"><a href="https://twitter.com/WPGU1071">Twitter</a></li>
	<li id="menu-item-33037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33037"><a href="http://www.facebook.com/wpgu1071">Facebook</a></li>
</ul>
</li>
<li id="menu-item-61412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61412"><a href="http://wpgu.com/video/">Video</a></li>
<li id="menu-item-61570" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61570"><a href="http://wpgu.com/advertise-with-us/">Advertise with us</a></li>
<li id="menu-item-61873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61873"><a href="http://wpgu.com/wpgu-concert-series-2/">Concert Series</a></li>
<li id="menu-item-62669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62669"><a href="http://wpgu.com/marathon/">The 26.2 Hour 1-Song Fundraiser</a></li>
</ul></div>					
											<div class="hm-search-button-icon"></div>
						<div class="hm-search-box-container">
							<div class="hm-search-box">
								<form role="search" method="get" class="search-form" action="http://wpgu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>							</div><!-- th-search-box -->
						</div><!-- .th-search-box-container -->
									</div><!-- .hm-container -->
			</nav><!-- #site-navigation -->
			<div class="hm-nwrap">
				<a href="#" class="navbutton" id="main-nav-button">Main Menu</a>
			</div>
			<div class="responsive-mainnav"></div>
		</div><!-- .hm-nav-container -->

		
	</header><!-- #masthead -->

	<div id="content" class="site-content">
		<div class="hm-container">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-62694" class="hitmag-single post-62694 post type-post status-publish format-standard has-post-thumbnail hentry category-album-reviews category-music tag-anderson-paak">
	<header class="entry-header">
		<div class="cat-links"><a href="http://wpgu.com/category/music/album-reviews/" rel="category tag">Album Reviews</a> / <a href="http://wpgu.com/category/music/" rel="category tag">Music</a></div><h1 class="entry-title">Anderson .Paak: Ventura</h1>		<div class="entry-meta">
			<span class="posted-on"><a href="http://wpgu.com/anderson-paak-ventura/" rel="bookmark"><time class="entry-date published" datetime="2019-04-18T11:33:30+00:00">April 18, 2019</time><time class="updated" datetime="2019-04-18T11:33:32+00:00">April 18, 2019</time></a></span><span class="meta-sep"> - </span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="http://wpgu.com/author/charles-rehder/">Charles Rehder</a></span></span>		</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->
	
	<img width="735" height="400" src="http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover-735x400.png" class="attachment-hitmag-featured size-hitmag-featured wp-post-image" alt="" /><div class="ccfic"></div>
	<div class="entry-content">
		
<p></p>



<figure class="wp-block-image"><img src="http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover-1.png" alt="" class="wp-image-62698" srcset="http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover-1.png 1000w, http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover-1-300x286.png 300w, http://wpgu.com/wp-content/uploads/2019/04/anderson-paak-ventura-album-artwork-cover-1-768x731.png 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></figure>



<p class="has-drop-cap">	Anderson .Paak had a busy 2018. Not only did he record his long-anticipated, third studio album, “Oxnard,” but also recorded enough material for a fourth album to be released soon after. Keeping with .Paak’s trend of naming albums after Californian cities, this latest record is called “Ventura” and it’s supposed to be the smoother, more R&amp;B influenced of his two latest releases. Having such a prolific musical city as the title of your album sets my expectations high, but .Paak may have reached them anyways. While I don’t think this album is as shockingly good as “Oxnard” was when I first heard it, after a few listens through “Ventura” I’m convinced it is still quite an impressive accomplishment.</p>



<p>	.Paak does what he can to shake up the formula that is the vintage R&amp;B/pop crossover hit, but there’s only so much you can do before some tracks start to stray from that genre label. The second single, “Make It Better,” manages to stay in that lane and delivers a pretty cute track. I’m sure I’ll begin to see how formulaic it is after more and more listens, but right now it’s the perfect track to put on when you want to pretend you’re in a rom-com. </p>



<p> Some of the less pop-centric tracks like “Winner’s Circle,” “Reachin’ 2 Much” and “Chosen One” really do showcase what’s so great about Anderson .Paak. The future-funk first half of “Reachin’ 2 Much” wasn’t something I expected after hearing the track prior, but I’m happy it’s on here. The beat sounds like a something off of a George Clinton 7 inch and .Paak’s chaotic drumming and vocals somehow fit the instrumental perfectly. “Winner’s Circle” is another great track with an insanely funky chorus and some buttery smooth verses that culminate into a great song. Anderson is at the top of his game when it comes to flows this album. His voice is rough and soulful and his staccato style rapping at the end of “Chosen One” proves he can ride a beat really well. </p>



<p> Just like on “Oxnard,” .Paak dedicates a couple of verses to criticism of the president. Bars like, “If they build a wall, let’s jump the fence, I’m over this” and, “But when I finally took a knee / Them crackers took me out the league” detail a few of the problems .Paak has with the president including his plans for a Mexican border wall and his targeting of former NFL quarterback Colin Kaepernick. Paak did something similar to this on “6 Summers” off “Oxnard” and if the trend keeps going we might have a funky, yet politically “woke” Anderson .Paak album coming in the future. It’s not exactly an album I would expect to find any social commentary on, but it by no means detracts from Anderson’s sound and adds some authenticity to his lyrics.</p>



<p>	The last track featuring Nate Dogg I didn’t really have high hopes for because I’ve been disappointed so much by posthumous features in hip hop, but .Paak really outdid himself on this track. It’s warm and fun and soulful and a great way to end the project. It sounds like Nate Dogg was meant to be on this track and it still fits perfectly into the sound .Paak is trying to cultivate. “What Can We Do?” is such a smooth track that it almost feels weird not listening to it with the top down on a perfect summer day. This song is the perfect ode to West Coast soul and the perfect way to use these otherwise lost Nate Dogg vocals.</p>



<p> I had high hopes for “Ventura” and after listening to it for a while I’m pretty satisfied. I’m not as blown away as I was with Oxnard but I’m far from disappointed with this release. It saw Anderson diverting from that West Coast hip hop sound in favor of something more soulful. It’s a great album to welcome in the summer months and despite a few misses on the tracklist Anderson .Paak pulls together a really good album that I would recommend to any fans of .Paak’s previous work or anybody curious about his sound.<br></p>
	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="hm-tags-links"><span class="hm-tagged">Tagged</span><a href="http://wpgu.com/tag/anderson-paak/" rel="tag">Anderson Paak</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->

    <div class="hm-related-posts">
    
    <div class="wt-container">
        <h4 class="widget-title">Related Posts</h4>
    </div>

    <div class="hmrp-container">

        
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/young-the-giant-mirror-master/" rel="bookmark" title="Young the Giant: Mirror Master">
                        <img width="348" height="215" src="http://wpgu.com/wp-content/uploads/2019/04/Young-the-Giant-348x215.png" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/young-the-giant-mirror-master/" rel="bookmark" title="Young the Giant: Mirror Master">
                            Young the Giant: Mirror Master                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-04-16T12:00:31+00:00">April 16, 2019</time><time class="updated" datetime="2019-04-15T23:32:03+00:00">April 15, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/girl-k-for-now/" rel="bookmark" title="Girl K: For Now">
                        <img width="348" height="215" src="http://wpgu.com/wp-content/uploads/2019/04/50670061_470661720131003_593416192266338304_n-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/girl-k-for-now/" rel="bookmark" title="Girl K: For Now">
                            Girl K: For Now                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-04-15T12:00:04+00:00">April 15, 2019</time><time class="updated" datetime="2019-04-14T11:33:18+00:00">April 14, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/quelle-chris-guns/" rel="bookmark" title="Quelle Chris: Guns">
                        <img width="348" height="215" src="http://wpgu.com/wp-content/uploads/2019/04/GUNS_cover_with_title_50204e60-3693-4775-bc11-63b773df35f4_1024x1024-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/quelle-chris-guns/" rel="bookmark" title="Quelle Chris: Guns">
                            Quelle Chris: Guns                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-04-13T13:35:16+00:00">April 13, 2019</time><time class="updated" datetime="2019-04-13T19:48:15+00:00">April 13, 2019</time></p>
                </div>
            
            
    </div>
    </div>

    <div class="hm-authorbox">

    <div class="hm-author-img">
        <img alt='' src='http://0.gravatar.com/avatar/68de6b452ee60312c02cc47ac084e8fb?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/68de6b452ee60312c02cc47ac084e8fb?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />    </div>

    <div class="hm-author-content">
        <h4 class="author-name">About Charles Rehder</h4>
        <p class="author-description">Your favorite Minnesotan. You can find Charles meticulously cleaning his records or eating Takis on the couch. Many said his career in music ended after middle school band, but he's here to defy expectations by proving it didn't end with the tenor saxophone. Charles is an avid listener of Kanye West, Mac DeMarco, Parquet Courts and many others. Hopefully he can help you find your new favorite tunes.</p>
        <a class="author-posts-link" href="http://wpgu.com/author/charles-rehder/" title="Charles Rehder">
            View all posts by Charles Rehder &rarr;        </a>
    </div>

</div>
		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area" role="complementary">
	<section id="custom_html-9" class="widget_text widget widget_custom_html"><h4 class="widget-title">livestream</h4><div class="textwidget custom-html-widget"><center>
<script type="application/javascript">document.write('<script src="//radio.securenetsystems.net/cirrusencore/livebutton/livebutton.cfm?stationcallsign=WPGUFM&buttonType=M&b=' +Math.random()+'"><\/script>');
</script>
</center></div></section><section id="bs_zones-2" class="widget bs_zones"><div><broadstreet-zone zone-id="69441" keywords="not_home_page,not_landing_page,is_article_page,album-reviews,music,music,anderson-paak-ventura,post" soft-keywords="true"></broadstreet-zone></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><h4 class="widget-title">Playlist</h4><div class="textwidget custom-html-widget"><iframe frameborder='no' scrolling='no' src='https://radio.securenetsystems.net/songdata/v5/index.cfm?stationCallSign=WPGUFM&width=573' allowtransparency='true' style='width:573px;height:250px;margin-top:10px;overflow-y:auto;overflow-x:hidden;border:1px solid #676767;'></iframe>
</div></section><section id="text-16" class="widget widget_text">			<div class="textwidget"><p><iframe src="https://dailyillini.friends2follow.com/f2f/widget/html/postfeed/46/0/12/140/1/2/1/10" width="100%" height="550px" frameborder="0" scrolling="no"></iframe></p>
</div>
		</section><section id="text-15" class="widget widget_text">			<div class="textwidget"><!--/* OpenX JavaScript tag */-->


<script type="text/javascript">
if (!window.OX_ads) { OX_ads = []; }
OX_ads.push({ "auid" : "536881946" });
</script>
<script type="text/javascript">
document.write('<scr'+'ipt src="//oncampusweb-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
</script>
<noscript><iframe id="b975e55388" name="b975e55388" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=536881946&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=b975e55388&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=536881946&cs=b975e55388&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript></div>
		</section></aside><!-- #secondary -->	</div><!-- .hm-container -->
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="hm-container">
			<div class="footer-widget-area">
				<div class="footer-sidebar" role="complementary">
											
									</div><!-- .footer-sidebar -->
		
				<div class="footer-sidebar" role="complementary">
					
									</div><!-- .footer-sidebar -->		

				<div class="footer-sidebar" role="complementary">
					
									</div><!-- .footer-sidebar -->			
			</div><!-- .footer-widget-area -->
		</div><!-- .hm-container -->

		<div class="site-info">
			<div class="hm-container">
				<div class="site-info-owner">
					Copyright &#169; 2019 <a href="http://wpgu.com/" title="WPGU 107.1" >WPGU 107.1</a>.				</div>			
				<div class="site-info-designer">
					Powered by <a href="https://wordpress.org" target="_blank" title="WordPress">WordPress</a> and <a href="https://themezhut.com/themes/hitmag/" target="_blank" title="HitMag WordPress Theme">HitMag</a>.				</div>
			</div><!-- .hm-container -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->


<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','album-reviews','music','music','anderson-paak-ventura','post']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["album-reviews","music","music","anderson-paak-ventura","post"],"url":"anderson-paak-ventura"};</script><script data-cfasync='false'>if (broadstreet) broadstreet.watch({});</script><script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/jquery.flexslider-min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/scripts.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/jquery.magnific-popup.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.0.0-beta.1'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/wp-embed.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
</body>
</html>