<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>Mac Miller: GO:OD AM - WPGU 107.1</title>

<!-- This site is optimized with the Yoast SEO plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://wpgu.com/mac-miller-good-am/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mac Miller: GO:OD AM - WPGU 107.1" />
<meta property="og:description" content="When Mac Miller lived, he was a well-deserved rapper. His work always had the good vibes of partying and good &hellip;" />
<meta property="og:url" content="http://wpgu.com/mac-miller-good-am/" />
<meta property="og:site_name" content="WPGU 107.1" />
<meta property="article:tag" content="mac miller" />
<meta property="article:tag" content="rap" />
<meta property="article:section" content="Album Reviews" />
<meta property="article:published_time" content="2019-05-02T17:00:37+00:00" />
<meta property="article:modified_time" content="2019-05-01T03:16:12+00:00" />
<meta property="og:updated_time" content="2019-05-01T03:16:12+00:00" />
<meta property="og:image" content="http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="When Mac Miller lived, he was a well-deserved rapper. His work always had the good vibes of partying and good &hellip;" />
<meta name="twitter:title" content="Mac Miller: GO:OD AM - WPGU 107.1" />
<meta name="twitter:image" content="http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Feed" href="http://wpgu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Comments Feed" href="http://wpgu.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.4.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.4.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1348014-23';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1348014-23', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wpgu.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='http://wpgu.com/wp-includes/css/dist/block-library/style.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='http://wpgu.com/wp-includes/css/dist/block-library/theme.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu%3A400%2C500%2C700%7CLato%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C400italic%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://wpgu.com/wp-content/plugins/employee-spotlight/assets/ext/font-awesome-4.7.0/css/font-awesome.min.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-style-css'  href='http://wpgu.com/wp-content/themes/hitmag/style.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-flexslider-css'  href='http://wpgu.com/wp-content/themes/hitmag/css/flexslider.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='screen' />
<link rel='stylesheet' id='jquery-magnific-popup-css'  href='http://wpgu.com/wp-content/themes/hitmag/css/magnific-popup.css?ver=5c003fa7634b6b409ca46e123c4e5d0a' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"http:\/\/wpgu.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wpgu.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.4.2'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/html5shiv.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://wpgu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wpgu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wpgu.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://wpgu.com/?p=62835' />
<link rel="alternate" type="application/json+oembed" href="http://wpgu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwpgu.com%2Fmac-miller-good-am%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wpgu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwpgu.com%2Fmac-miller-good-am%2F&#038;format=xml" />
<meta name="generator" content="Employee Spotlight v4.6.0 - https://emdplugins.com" />
          <style>
          .has-post-thumbnail img.wp-post-image, 
          .attachment-twentyseventeen-featured-image.wp-post-image { display: none !important; }          
          </style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//wpgu.com/?wordfence_lh=1&hid=B0FD6932F70885973DA882CFFE468EAE');
</script>		<style type="text/css">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</style>
		<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}
			
			
		</style>
	<link rel="icon" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01-125x125.png" sizes="32x32" />
<link rel="icon" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" />
<meta name="msapplication-TileImage" content="http://wpgu.com/wp-content/uploads/2016/01/favicon-01.png" />
</head>

<body class="post-template-default single single-post postid-62835 single-format-standard wp-custom-logo group-blog th-right-sidebar">

<div id="page" class="site hitmag-wrapper">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		
		
		<div class="header-main-area">
			<div class="hm-container">
			<div class="site-branding">
				<div class="site-branding-content">
					<div class="hm-logo">
						<a href="http://wpgu.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="240" height="80" src="http://wpgu.com/wp-content/uploads/2018/12/hireswpgu2.png" class="custom-logo" alt="WPGU 107.1" itemprop="logo" /></a>					</div><!-- .hm-logo -->

					<div class="hm-site-title">
													<p class="site-title"><a href="http://wpgu.com/" rel="home">WPGU 107.1</a></p>
													<p class="site-description">Champaign&#039;s Alternative</p>
											</div><!-- .hm-site-title -->
				</div><!-- .site-branding-content -->
			</div><!-- .site-branding -->

			<div class="hm-header-sidebar"><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="70082"></broadstreet-zone>
</div></aside></div>			</div><!-- .hm-container -->
		</div><!-- .header-main-area -->

		
		<div class="hm-nav-container">
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="hm-container">
					<div class="menu-top-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-33039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-33039"><a href="http://wpgu.com/about-us/">About</a>
<ul class="sub-menu">
	<li id="menu-item-33159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33159"><a href="http://wpgu.com/staff/">Directors</a></li>
	<li id="menu-item-61971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61971"><a href="http://wpgu.com/on-air-personalities-2/">On-air personalities</a></li>
	<li id="menu-item-60878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60878"><a href="http://wpgu.com/web-writers/">Web writers</a></li>
	<li id="menu-item-45859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45859"><a href="http://wpgu.com/music-submission/">Music Submission</a></li>
	<li id="menu-item-54799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54799"><a href="http://wpgu.com/contact-wpgu/">Contact us / support</a></li>
	<li id="menu-item-58717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58717"><a href="http://wpgu.com/apply/">Internships</a></li>
</ul>
</li>
<li id="menu-item-59827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59827"><a href="http://wpgu.com/category/on-air/">On-Air</a>
<ul class="sub-menu">
	<li id="menu-item-59640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59640"><a href="http://wpgu.com/category/can-i-kick-it-podcast/">CAN I KICK IT &#8211; PODCAST</a></li>
	<li id="menu-item-62123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62123"><a href="http://wpgu.com/category/writers-block/">Writer&#8217;s Block</a></li>
	<li id="menu-item-60794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60794"><a href="http://wpgu.com/category/loud-local/">Loud and Local</a></li>
	<li id="menu-item-61512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61512"><a href="http://wpgu.com/category/request-live/">Request Live</a></li>
	<li id="menu-item-61894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61894"><a href="http://wpgu.com/category/flashback-cafe/">Flashback Cafe</a></li>
	<li id="menu-item-61481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61481"><a href="http://wpgu.com/category/rollin-illini/">Rollin&#8217; Illini</a></li>
	<li id="menu-item-61895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61895"><a href="http://wpgu.com/category/illini-drive/">Illini Drive</a></li>
	<li id="menu-item-60795" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60795"><a href="http://wpgu.com/category/take-it-away/">Take It Away</a></li>
	<li id="menu-item-59828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59828"><a href="http://wpgu.com/category/music/interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-33162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-33162"><a href="http://wpgu.com/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-41883" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-41883"><a href="http://wpgu.com/category/music/album-reviews/">Album Reviews</a></li>
	<li id="menu-item-59847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59847"><a href="http://wpgu.com/category/music/music-news/">Music News</a></li>
	<li id="menu-item-59848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59848"><a href="http://wpgu.com/category/shows/previews/">Concert Previews</a></li>
	<li id="menu-item-59846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59846"><a href="http://wpgu.com/category/shows/concertreviews/">Concert Reviews</a></li>
</ul>
</li>
<li id="menu-item-54800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-54800"><a href="#">Social</a>
<ul class="sub-menu">
	<li id="menu-item-54802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54802"><a href="https://www.instagram.com/wpguillini/">Instagram</a></li>
	<li id="menu-item-54801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54801"><a href="https://twitter.com/WPGU1071">Twitter</a></li>
	<li id="menu-item-33037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33037"><a href="http://www.facebook.com/wpgu1071">Facebook</a></li>
</ul>
</li>
<li id="menu-item-61412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61412"><a href="http://wpgu.com/video/">Video</a></li>
<li id="menu-item-61570" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61570"><a href="http://wpgu.com/advertise-with-us/">Advertise with us</a></li>
<li id="menu-item-61873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61873"><a href="http://wpgu.com/wpgu-concert-series-2/">Concert Series</a></li>
<li id="menu-item-62669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62669"><a href="http://wpgu.com/marathon/">The 26.2 Hour 1-Song Fundraiser</a></li>
</ul></div>					
											<div class="hm-search-button-icon"></div>
						<div class="hm-search-box-container">
							<div class="hm-search-box">
								<form role="search" method="get" class="search-form" action="http://wpgu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>							</div><!-- th-search-box -->
						</div><!-- .th-search-box-container -->
									</div><!-- .hm-container -->
			</nav><!-- #site-navigation -->
			<div class="hm-nwrap">
				<a href="#" class="navbutton" id="main-nav-button">Main Menu</a>
			</div>
			<div class="responsive-mainnav"></div>
		</div><!-- .hm-nav-container -->

		
	</header><!-- #masthead -->

	<div id="content" class="site-content">
		<div class="hm-container">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-62835" class="hitmag-single post-62835 post type-post status-publish format-standard hentry category-album-reviews category-music tag-mac-miller tag-rap">
	<header class="entry-header">
		<div class="cat-links"><a href="http://wpgu.com/category/music/album-reviews/" rel="category tag">Album Reviews</a> / <a href="http://wpgu.com/category/music/" rel="category tag">Music</a></div><h1 class="entry-title">Mac Miller: GO:OD AM</h1>		<div class="entry-meta">
			<span class="posted-on"><a href="http://wpgu.com/mac-miller-good-am/" rel="bookmark"><time class="entry-date published" datetime="2019-05-02T12:00:37+00:00">May 2, 2019</time><time class="updated" datetime="2019-04-30T22:16:12+00:00">April 30, 2019</time></a></span><span class="meta-sep"> - </span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="http://wpgu.com/author/boomme3/">Brenda Oommen</a></span></span>		</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->
	
	<div class="ccfic"></div>
	<div class="entry-content">
		
<div class="wp-block-image"><figure class="aligncenter is-resized"><img src="http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg.jpg" alt="" class="wp-image-62843" width="443" height="443" srcset="http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg.jpg 1200w, http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg-150x150.jpg 150w, http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg-300x300.jpg 300w, http://wpgu.com/wp-content/uploads/2019/04/mac-miller-good-amjpg-768x768.jpg 768w" sizes="(max-width: 443px) 100vw, 443px" /></figure></div>



<p class="has-drop-cap">When Mac Miller lived, he was a well-deserved rapper. His work always had the good vibes of partying and good ideas. Mac’s personality is the kind that makes you never wonder what he might be up to, either because he’s already told you or you could probably just tell. This album especially is a comical representation of his personality; he did not give a hoot or a holler. If you’ve ever listened to Mac Miller, you never need to be reintroduced to the ideas he offers through these songs. They’re centrally focused on his success and his desire for the entire amount to always be more.<br></p>



<p>“It’s not about complaining; it’s not about maintaining.” (Rush Hour 2015). Mac doesn’t have any problem with fun, in fact, it might the only thing he’s truly in love with. This is at least what a listener might hear from his voice; it’s not a party. It’s a parade, as the collaboration of what Mac brings and what Ab-Soul brings on his feature in &#8220;Two Matches.&#8221; In this lifetime, Mac Miller found himself seeing things far crazier than anyone else; this is exactly what one might think. Why would he make an entire album convincing of us? We get it, Mac, you’re a monster…and you smoke lots of weed.</p>



<p>But Mac doesn’t let you believe he actually is that simple. If I could count how many times he mentions his childhood, I’d actually have to try. That’s the problem with this album; it’s actually a good time. A caveat, a warning, a bit of a ‘beware’ to the potential addictions of life. Mac never actually admits to trying to change the world, but his popular songs in this album: &#8220;Donald Trump,&#8221; &#8220;100 Grandkids&#8221; and &#8220;Break the Law&#8221; might encourage differently. He’s not just sentimental though. He’s humble when he tries; &#8220;100 Grandkids&#8221; is never about the money. It’s about how he developed fame, achieved some goals, and couldn’t help but let the accomplishments be so valuable, he couldn’t help but let everyone know. Ultimately, if you let Mac tell you he is going to make a plan, he’s going to let it happen. He thought he was a king once for it, even blocking the haters out, but he found his footing in the wet sand of success.</p>



<p> Since the album refers to the GO:OD time being apparently in the morning, the song &#8220;Time Flies&#8221; (feat Lil. B) could be considered relatively important. It’s all about him though. If I had to teach someone how to be confident, I’d introduce you to this artist. Mac Miller isn’t just owning up to his importance, but he refers to every achievement throughout the album as a whole.<br> </p>



<p>The rest of the album exalts his soul, and I couldn’t have introduced Mac to the mainstream world of pop and rap in any other manner that just abusing his own name. “There’s something about it, and it just freaks me out” (What’s the Use 2018). If you get a second, check out his NPR’S Tiny Desk concert where his cockiness is coated in tones of jazz, in case you couldn’t handle the bizarre confidence Mac carries.</p>
	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="hm-tags-links"><span class="hm-tagged">Tagged</span><a href="http://wpgu.com/tag/mac-miller/" rel="tag">mac miller</a><a href="http://wpgu.com/tag/rap/" rel="tag">rap</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->

    <div class="hm-related-posts">
    
    <div class="wt-container">
        <h4 class="widget-title">Related Posts</h4>
    </div>

    <div class="hmrp-container">

        
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/kevin-morby-oh-my-god/" rel="bookmark" title="Kevin Morby: Oh My God">
                        <img width="348" height="215" src="http://wpgu.com/wp-content/uploads/2019/05/a1951484437_10-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/kevin-morby-oh-my-god/" rel="bookmark" title="Kevin Morby: Oh My God">
                            Kevin Morby: Oh My God                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-05-01T15:07:00+00:00">May 1, 2019</time><time class="updated" datetime="2019-05-01T15:07:01+00:00">May 1, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/local-natives-violet-street/" rel="bookmark" title="Local Natives: Violet Street">
                        <div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/local-natives-violet-street/" rel="bookmark" title="Local Natives: Violet Street">
                            Local Natives: Violet Street                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-04-30T00:00:03+00:00">April 30, 2019</time><time class="updated" datetime="2019-04-30T11:10:02+00:00">April 30, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="http://wpgu.com/other-creatures-coko/" rel="bookmark" title="Other Creatures: Coko">
                        <div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="http://wpgu.com/other-creatures-coko/" rel="bookmark" title="Other Creatures: Coko">
                            Other Creatures: Coko                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-04-24T12:00:39+00:00">April 24, 2019</time><time class="updated" datetime="2019-04-22T20:51:09+00:00">April 22, 2019</time></p>
                </div>
            
            
    </div>
    </div>

    <div class="hm-authorbox">

    <div class="hm-author-img">
        <img alt='' src='http://2.gravatar.com/avatar/5d22a927c51ae09ebe758bc331c0dd46?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/5d22a927c51ae09ebe758bc331c0dd46?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />    </div>

    <div class="hm-author-content">
        <h4 class="author-name">About Brenda Oommen</h4>
        <p class="author-description">Brenda loves to sing and play guitar while working on her writings for WPGU and her classes that focus on adult development and interpersonal communication. She also dances in her free time and tends to enjoy shows like the Office and some of her favorite artists include Fleetwood Mac, Tame Impala, and Action Bronson.</p>
        <a class="author-posts-link" href="http://wpgu.com/author/boomme3/" title="Brenda Oommen">
            View all posts by Brenda Oommen &rarr;        </a>
    </div>

</div>
		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area" role="complementary">
	<section id="custom_html-9" class="widget_text widget widget_custom_html"><h4 class="widget-title">livestream</h4><div class="textwidget custom-html-widget"><center>
<script type="application/javascript">document.write('<script src="//radio.securenetsystems.net/cirrusencore/livebutton/livebutton.cfm?stationcallsign=WPGUFM&buttonType=M&b=' +Math.random()+'"><\/script>');
</script>
</center></div></section><section id="bs_zones-2" class="widget bs_zones"><div><broadstreet-zone zone-id="69441" keywords="not_home_page,not_landing_page,is_article_page,album-reviews,music,music,mac-miller-good-am,post" soft-keywords="true"></broadstreet-zone></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><h4 class="widget-title">Playlist</h4><div class="textwidget custom-html-widget"><iframe frameborder='no' scrolling='no' src='https://radio.securenetsystems.net/songdata/v5/index.cfm?stationCallSign=WPGUFM&width=573' allowtransparency='true' style='width:573px;height:250px;margin-top:10px;overflow-y:auto;overflow-x:hidden;border:1px solid #676767;'></iframe>
</div></section><section id="text-16" class="widget widget_text">			<div class="textwidget"><p><iframe src="https://dailyillini.friends2follow.com/f2f/widget/html/postfeed/46/0/12/140/1/2/1/10" width="100%" height="550px" frameborder="0" scrolling="no"></iframe></p>
</div>
		</section><section id="text-15" class="widget widget_text">			<div class="textwidget"><!--/* OpenX JavaScript tag */-->


<script type="text/javascript">
if (!window.OX_ads) { OX_ads = []; }
OX_ads.push({ "auid" : "536881946" });
</script>
<script type="text/javascript">
document.write('<scr'+'ipt src="//oncampusweb-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
</script>
<noscript><iframe id="b975e55388" name="b975e55388" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=536881946&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=b975e55388&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=536881946&cs=b975e55388&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript></div>
		</section></aside><!-- #secondary -->	</div><!-- .hm-container -->
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="hm-container">
			<div class="footer-widget-area">
				<div class="footer-sidebar" role="complementary">
											
									</div><!-- .footer-sidebar -->
		
				<div class="footer-sidebar" role="complementary">
					
									</div><!-- .footer-sidebar -->		

				<div class="footer-sidebar" role="complementary">
					
									</div><!-- .footer-sidebar -->			
			</div><!-- .footer-widget-area -->
		</div><!-- .hm-container -->

		<div class="site-info">
			<div class="hm-container">
				<div class="site-info-owner">
					Copyright &#169; 2019 <a href="http://wpgu.com/" title="WPGU 107.1" >WPGU 107.1</a>.				</div>			
				<div class="site-info-designer">
					Powered by <a href="https://wordpress.org" target="_blank" title="WordPress">WordPress</a> and <a href="https://themezhut.com/themes/hitmag/" target="_blank" title="HitMag WordPress Theme">HitMag</a>.				</div>
			</div><!-- .hm-container -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->


<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','album-reviews','music','music','mac-miller-good-am','post']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["album-reviews","music","music","mac-miller-good-am","post"],"url":"mac-miller-good-am"};</script><script data-cfasync='false'>if (broadstreet) broadstreet.watch({});</script><script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/jquery.flexslider-min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/scripts.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/themes/hitmag/js/jquery.magnific-popup.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
<script type='text/javascript' src='http://wpgu.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.0.0-beta.1'></script>
<script type='text/javascript' src='http://wpgu.com/wp-includes/js/wp-embed.min.js?ver=5c003fa7634b6b409ca46e123c4e5d0a'></script>
</body>
</html>