<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>The Top 50 Albums and EPs of 2019 - WPGU 107.1</title>

<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://wpgu.com/the-top-50-albums-and-eps-of-2019/" />
<link rel="next" href="https://wpgu.com/the-top-50-albums-and-eps-of-2019/2/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Top 50 Albums and EPs of 2019 - WPGU 107.1" />
<meta property="og:description" content="This past semester, the web writers grew to a team of 20 writers, the biggest team our staff has seen &hellip;" />
<meta property="og:url" content="https://wpgu.com/the-top-50-albums-and-eps-of-2019/" />
<meta property="og:site_name" content="WPGU 107.1" />
<meta property="article:section" content="Music" />
<meta property="article:published_time" content="2019-12-31T19:25:59+00:00" />
<meta property="article:modified_time" content="2019-12-31T19:26:02+00:00" />
<meta property="og:updated_time" content="2019-12-31T19:26:02+00:00" />
<meta property="og:image" content="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg" />
<meta property="og:image:secure_url" content="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg" />
<meta property="og:image:width" content="1800" />
<meta property="og:image:height" content="1200" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="This past semester, the web writers grew to a team of 20 writers, the biggest team our staff has seen &hellip;" />
<meta name="twitter:title" content="The Top 50 Albums and EPs of 2019 - WPGU 107.1" />
<meta name="twitter:image" content="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://wpgu.com/#website","url":"https://wpgu.com/","name":"WPGU 107.1","potentialAction":{"@type":"SearchAction","target":"https://wpgu.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://wpgu.com/the-top-50-albums-and-eps-of-2019/#primaryimage","url":"https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg","width":1800,"height":1200},{"@type":"WebPage","@id":"https://wpgu.com/the-top-50-albums-and-eps-of-2019/#webpage","url":"https://wpgu.com/the-top-50-albums-and-eps-of-2019/","inLanguage":"en-US","name":"The Top 50 Albums and EPs of 2019 - WPGU 107.1","isPartOf":{"@id":"https://wpgu.com/#website"},"primaryImageOfPage":{"@id":"https://wpgu.com/the-top-50-albums-and-eps-of-2019/#primaryimage"},"datePublished":"2019-12-31T19:25:59+00:00","dateModified":"2019-12-31T19:26:02+00:00","author":{"@id":"https://wpgu.com/#/schema/person/ef152eb5b51c7ec5a49122bcc4e74612"}},{"@type":["Person"],"@id":"https://wpgu.com/#/schema/person/ef152eb5b51c7ec5a49122bcc4e74612","name":"WPGU Music Staff","image":{"@type":"ImageObject","@id":"https://wpgu.com/#authorlogo","url":"https://secure.gravatar.com/avatar/46de021ddcb03841dd5331878e92f0b8?s=96&d=mm&r=g","caption":"WPGU Music Staff"},"description":"We're a gang of music lovers.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Feed" href="https://wpgu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WPGU 107.1 &raquo; Comments Feed" href="https://wpgu.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1348014-23';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1348014-23', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wpgu.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=62da2895fa89406029318a061f41db85"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://wpgu.com/wp-includes/css/dist/block-library/style.min.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://wpgu.com/wp-includes/css/dist/block-library/theme.min.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu%3A400%2C500%2C700%7CLato%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C400italic%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://wpgu.com/wp-content/plugins/employee-spotlight/assets/ext/font-awesome-4.7.0/css/font-awesome.min.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-style-css'  href='https://wpgu.com/wp-content/themes/hitmag/style.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-flexslider-css'  href='https://wpgu.com/wp-content/themes/hitmag/css/flexslider.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='screen' />
<link rel='stylesheet' id='jquery-magnific-popup-css'  href='https://wpgu.com/wp-content/themes/hitmag/css/magnific-popup.css?ver=62da2895fa89406029318a061f41db85' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/wpgu.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wpgu.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.0'></script>
<script type='text/javascript' data-cfasync='false' async src='//cdn.broadstreetads.com/init-2.min.js?ver=62da2895fa89406029318a061f41db85'></script>
<script type='text/javascript' src='https://wpgu.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://wpgu.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/html5shiv.min.js?ver=62da2895fa89406029318a061f41db85'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://wpgu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wpgu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wpgu.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wpgu.com/?p=63965' />
<link rel="alternate" type="application/json+oembed" href="https://wpgu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwpgu.com%2Fthe-top-50-albums-and-eps-of-2019%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wpgu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwpgu.com%2Fthe-top-50-albums-and-eps-of-2019%2F&#038;format=xml" />
<meta name="generator" content="Employee Spotlight v4.6.1 - https://emdplugins.com" />
          <style>
          .has-post-thumbnail img.wp-post-image, 
          .attachment-twentyseventeen-featured-image.wp-post-image { display: none !important; }          
          </style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//wpgu.com/?wordfence_lh=1&hid=D77954615F3551B748B1834DCF7DEAE3');
</script>		<style type="text/css">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</style>
		<style type="text/css">

			.site-title a,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}

	
	</style>
	<link rel="icon" href="https://wpgu.com/wp-content/uploads/2019/08/cropped-WPGU_image-for-app-32x32.png" sizes="32x32" />
<link rel="icon" href="https://wpgu.com/wp-content/uploads/2019/08/cropped-WPGU_image-for-app-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://wpgu.com/wp-content/uploads/2019/08/cropped-WPGU_image-for-app-180x180.png" />
<meta name="msapplication-TileImage" content="https://wpgu.com/wp-content/uploads/2019/08/cropped-WPGU_image-for-app-270x270.png" />
</head>

<body class="post-template-default single single-post postid-63965 single-format-standard wp-custom-logo group-blog th-no-sidebar">



<div id="page" class="site hitmag-wrapper">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header" role="banner">

		
		
		<div class="header-main-area ">
			<div class="hm-container">
			<div class="site-branding">
				<div class="site-branding-content">
					<div class="hm-logo">
						<a href="https://wpgu.com/" class="custom-logo-link" rel="home"><img width="470" height="158" src="https://wpgu.com/wp-content/uploads/2019/08/WPGU-logo-horizontal_orange-1-e1566225759339.png" class="custom-logo" alt="WPGU 107.1" /></a>					</div><!-- .hm-logo -->

					<div class="hm-site-title">
													<p class="site-title"><a href="https://wpgu.com/" rel="home">WPGU 107.1</a></p>
													<p class="site-description">Champaign&#039;s Alternative</p>
											</div><!-- .hm-site-title -->
				</div><!-- .site-branding-content -->
			</div><!-- .site-branding -->

			
			<div class="hm-header-sidebar"><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="70082"></broadstreet-zone>
</div></aside></div>			</div><!-- .hm-container -->
		</div><!-- .header-main-area -->

		
		<div class="hm-nav-container">
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="hm-container">
					<div class="menu-top-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-33039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-33039"><a href="https://wpgu.com/about-us/">About</a>
<ul class="sub-menu">
	<li id="menu-item-33159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33159"><a href="https://wpgu.com/staff/">Directors</a></li>
	<li id="menu-item-61971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61971"><a href="https://wpgu.com/on-air-personalities-2/">On-Air Personalities</a></li>
	<li id="menu-item-60878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60878"><a href="https://wpgu.com/web-writers/">Web Writers</a></li>
	<li id="menu-item-54799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54799"><a href="https://wpgu.com/contact/">Contact</a></li>
	<li id="menu-item-58717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58717"><a href="https://wpgu.com/apply/">Internships</a></li>
	<li id="menu-item-45859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45859"><a href="https://wpgu.com/music-submission/">Music Submission</a></li>
	<li id="menu-item-61570" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61570"><a href="https://wpgu.com/advertise-with-us/">Advertise with us</a></li>
</ul>
</li>
<li id="menu-item-59827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59827"><a href="https://wpgu.com/category/on-air/">On-Air</a>
<ul class="sub-menu">
	<li id="menu-item-59640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59640"><a href="https://wpgu.com/category/can-i-kick-it/">Can I Kick It</a></li>
	<li id="menu-item-62123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62123"><a href="https://wpgu.com/category/writers-block/">Writer&#8217;s Block</a></li>
	<li id="menu-item-60794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60794"><a href="https://wpgu.com/category/loud-local/">Loud and Local</a></li>
	<li id="menu-item-61512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61512"><a href="https://wpgu.com/category/request-live/">Request Live</a></li>
	<li id="menu-item-63505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63505"><a href="https://wpgu.com/illini-drive/">Illini Drive</a></li>
	<li id="menu-item-63512" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63512"><a href="https://wpgu.com/rollin-illini/">Rollin&#8217; Illini</a></li>
	<li id="menu-item-63516" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63516"><a href="https://wpgu.com/flashback-cafe/">Flashback Cafe</a></li>
	<li id="menu-item-60795" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60795"><a href="https://wpgu.com/category/take-it-away/">Take It Away</a></li>
	<li id="menu-item-59828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59828"><a href="https://wpgu.com/category/music/interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-33162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-33162"><a href="https://wpgu.com/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-41883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41883"><a href="https://wpgu.com/category/music/album-reviews/">Album Reviews</a></li>
	<li id="menu-item-59847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59847"><a href="https://wpgu.com/category/music/music-news/">Music News</a></li>
	<li id="menu-item-59848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59848"><a href="https://wpgu.com/category/shows/previews/">Concert Previews</a></li>
	<li id="menu-item-59846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59846"><a href="https://wpgu.com/category/shows/concertreviews/">Concert Reviews</a></li>
</ul>
</li>
<li id="menu-item-54800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-54800"><a href="#">Social</a>
<ul class="sub-menu">
	<li id="menu-item-54802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54802"><a href="https://www.instagram.com/wpguillini/">Instagram</a></li>
	<li id="menu-item-54801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54801"><a href="https://twitter.com/WPGU1071">Twitter</a></li>
	<li id="menu-item-33037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33037"><a href="http://www.facebook.com/wpgu1071">Facebook</a></li>
	<li id="menu-item-61412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61412"><a href="https://wpgu.com/video/">Video</a></li>
	<li id="menu-item-63326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63326"><a href="https://wpgu.com/wpgu-107-1fm-app/">App</a></li>
</ul>
</li>
<li id="menu-item-61873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61873"><a href="https://wpgu.com/wpgu-concert-series-2/">Concert Series</a></li>
<li id="menu-item-63266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63266"><a href="https://wpgu.com/wpgu-ultimate-song-battle/">Song Battle</a></li>
<li id="menu-item-63380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63380"><a href="https://wpgu.com/restaurant-of-the-month/">Restaurant of the Month</a></li>
</ul></div>					
											<div class="hm-search-button-icon"></div>
						<div class="hm-search-box-container">
							<div class="hm-search-box">
								<form role="search" method="get" class="search-form" action="https://wpgu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>							</div><!-- th-search-box -->
						</div><!-- .th-search-box-container -->
									</div><!-- .hm-container -->
			</nav><!-- #site-navigation -->
			<div class="hm-nwrap">
				<a href="#" class="navbutton" id="main-nav-button">Main Menu</a>
			</div>
			<div class="responsive-mainnav"></div>
		</div><!-- .hm-nav-container -->

		
	</header><!-- #masthead -->

	
	<div id="content" class="site-content">
		<div class="hm-container">
	
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-63965" class="hitmag-single post-63965 post type-post status-publish format-standard has-post-thumbnail hentry category-music">

	
	<header class="entry-header">
		<div class="cat-links"><a href="https://wpgu.com/category/music/" rel="category tag">Music</a></div><h1 class="entry-title">The Top 50 Albums and EPs of 2019</h1>		<div class="entry-meta">
			<span class="posted-on"><a href="https://wpgu.com/the-top-50-albums-and-eps-of-2019/" rel="bookmark"><time class="entry-date published" datetime="2019-12-31T13:25:59-06:00">December 31, 2019</time><time class="updated" datetime="2019-12-31T13:26:02-06:00">December 31, 2019</time></a></span><span class="meta-sep"> - </span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://wpgu.com/author/wpgu-music-staff/">WPGU Music Staff</a></span></span>		</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->
	
	<img width="1120" height="450" src="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1-1120x450.jpg" class="attachment-hitmag-landscape size-hitmag-landscape wp-post-image" alt="" /><div class="ccfic"></div>
	
	<div class="entry-content">
		
<figure class="wp-block-image"><img src="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg" alt="" class="wp-image-64015" srcset="https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1.jpg 1800w, https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1-300x200.jpg 300w, https://wpgu.com/wp-content/uploads/2019/12/top50-graphic-1-768x512.jpg 768w" sizes="(max-width: 1800px) 100vw, 1800px" /><figcaption>Graphic by Kyra Puetz</figcaption></figure>



<p class="has-drop-cap">This past semester, the web writers grew to a team of 20 writers, the biggest team our staff has seen in years. With a bigger team, there&#8217;s been such a diverse taste in music which almost makes this list hard to make. Well, that and the constant stream of music, both good and bad, that has been released this year. Nevertheless, the ranking of the top 50 albums has become a favorite among the web writers, who graciously gave up a whole Saturday before finals to discuss some of the best albums of 2019. The WPGU writing staff proudly presents our top 50 albums and EPs of 2019, along with a writeup of each staff member&#8217;s personal favorite album of 2019. Enjoy!</p>



<hr class="wp-block-separator"/>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>50.</strong> <strong>Oliver Tree &#8211; Do You Feel Me?</strong></p>
</div>



<div class="wp-block-column">
<p><strong>40. The National &#8211; I Am Easy To Find</strong></p>
</div>



<div class="wp-block-column">
<p><strong>30. Ana Frango Electrico- Little Electric Chicken Heat</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/freddie-gibbs-madlib-bandana/">20. Freddie Gibbs &amp; Madlib &#8211; Bandana</a></strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/cage-the-elephant-social-cues/">49. Cage the Elephant &#8211; Social Cues</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/le-butcherettes-bi-mental/">39. Le Butcherettes- bi/MENTAL</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>29. Jay Som &#8211; Anak Ko </strong></p>
</div>



<div class="wp-block-column">
<p><strong>19. Lizzo &#8211; Cuz I Love You</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/djo-twenty-twenty/">48. Djo &#8211; Twenty Twenty</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>38. YBN Cordae &#8211; The Lost Boy</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/local-natives-violet-street/">28. Local Natives &#8211; Violet Street</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/hippo-campus-demos-ii/">18. Hippo Campus &#8211; Demos II </a></strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>47. (Sandy) Alex G &#8211; House of Sugar</strong></p>
</div>



<div class="wp-block-column">
<p><strong>37. James Blake &#8211; Assume Form</strong></p>
</div>



<div class="wp-block-column">
<p><strong>27. Faye Webster &#8211; Atlanta Millionaires Club</strong></p>
</div>



<div class="wp-block-column">
<p><strong>17. Xiu Xiu- Girl with basket of fruit</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>46. DaBaby &#8211; Baby on Baby</strong></p>
</div>



<div class="wp-block-column">
<p><strong>36. Chai &#8211; PUNK</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/nick-cave-and-the-bad-seeds-ghosteen/">26. Nick Cave &amp; The Bad Seeds &#8211; Ghosteen</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>16. JPEGMAFIA &#8211; ALL MY HEROES ARE CORNBALLS</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>45. Caroline Polachek &#8211; Pang</strong></p>
</div>



<div class="wp-block-column">
<p><strong>35. Snapped Ankles &#8211; Stunning Luxury</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/brockhampton-ginger/">25. BROCKHAMPTON &#8211; GINGER</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>15. ITEKOMA HITS- Otoboke Beaver</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/ariana-grande-thank-u-next/">44. Ariana Grande &#8211; thank u, next</a> </strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/twin-peaks-lookout-low/">34. Twin Peaks &#8211; Lookout Low</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>24. Bon Iver &#8211; i, i </strong></p>
</div>



<div class="wp-block-column">
<p><strong>14. Billie Ellish &#8211; When We All Fall Asleep, Where Do We Go?</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>43. Ex Okays &#8211; Good/Old Days EP</strong></p>
</div>



<div class="wp-block-column">
<p><strong>33. Angel Olsen &#8211; All Mirrors</strong></p>
</div>



<div class="wp-block-column">
<p><strong>23. Vampire Weekend &#8211; Father of the Bride</strong></p>
</div>



<div class="wp-block-column">
<p><strong>13. Lana Del Rey &#8211; Norman Fucking Rockwell!</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>42. Danny Brown &#8211; uknowwhatimsayin¿</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/quelle-chris-guns/">32. Quelle Chris- Guns</a></strong></p>
</div>



<div class="wp-block-column">
<p><strong>22. Weyes Blood &#8211; Titanic Rising</strong></p>
</div>



<div class="wp-block-column">
<p><strong>12. Big Thief &#8211; U.F.O.F.</strong></p>
</div>
</div>



<div class="wp-block-columns has-4-columns">
<div class="wp-block-column">
<p><strong>41. 100 gecs &#8211; 1000 gecs</strong></p>
</div>



<div class="wp-block-column">
<p><strong>31. Denzel Curry &#8211; ZUU</strong></p>
</div>



<div class="wp-block-column">
<p><strong>21. Julia Jacklin &#8211; Crushing</strong></p>
</div>



<div class="wp-block-column">
<p><strong><a href="https://wpgu.com/weatherday-come-in/">11. Weather Day &#8211; Come In</a></strong></p>
</div>
</div>



<div class="wp-block-media-text alignwide"><figure class="wp-block-media-text__media"><img src="https://wpgu.com/wp-content/uploads/2019/12/top-10.jpg" alt="" class="wp-image-64077" srcset="https://wpgu.com/wp-content/uploads/2019/12/top-10.jpg 1200w, https://wpgu.com/wp-content/uploads/2019/12/top-10-200x300.jpg 200w, https://wpgu.com/wp-content/uploads/2019/12/top-10-768x1152.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></figure><div class="wp-block-media-text__content">
<p style="text-align:left" class="has-medium-font-size"><a href="https://wpgu.com/maggie-rogers-heard-it-in-a-past-life/">10. Maggie Rogers &#8211; Heard It In A Past Life</a></p>



<p style="text-align:left" class="has-medium-font-size">9. Purple Mountains &#8211; Purple Mountains</p>



<p style="text-align:left" class="has-medium-font-size"><a href="https://wpgu.com/big-thief-two-hands/">8. Big Thief &#8211; Two Hands</a></p>



<p style="text-align:left" class="has-medium-font-size"><a href="https://wpgu.com/solage-when-i-get-home/">7. Solange &#8211; When I Get Home</a></p>



<p style="text-align:left" class="has-medium-font-size">6. Clairo &#8211; Immunity</p>



<p style="text-align:left" class="has-medium-font-size">5. Whitney &#8211; Forever Turned Around</p>



<p style="text-align:left" class="has-medium-font-size"><a href="https://wpgu.com/wallows-nothing-matters/">4. Wallows &#8211; Nothing Happens</a></p>



<p style="text-align:left" class="has-medium-font-size">3. Toro y Moi &#8211; Outer Peace</p>



<p style="text-align:left" class="has-medium-font-size">2. FKA Twigs &#8211; MAGDALENE</p>



<p style="text-align:left" class="has-medium-font-size"><a href="https://wpgu.com/tyler-the-creator-igor/">1. Tyler, The Creator &#8211; IGOR</a></p>



<p class="has-large-font-size"></p>
</div></div>


<div class="page-links">Pages: <span class="post-page-numbers current" aria-current="page">1</span> <a href="https://wpgu.com/the-top-50-albums-and-eps-of-2019/2/" class="post-page-numbers">2</a></div>	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
			</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
    <div class="hm-related-posts">
    
    <div class="wt-container">
        <h4 class="widget-title">Related Posts</h4>
    </div>

    <div class="hmrp-container">

        
                <div class="hm-rel-post">
                    <a href="https://wpgu.com/top-albums-of-the-decade/" rel="bookmark" title="Top Albums of the Decade">
                        <img width="348" height="215" src="https://wpgu.com/wp-content/uploads/2019/12/decade-graphic-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="https://wpgu.com/top-albums-of-the-decade/" rel="bookmark" title="Top Albums of the Decade">
                            Top Albums of the Decade                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-12-30T16:54:33-06:00">December 30, 2019</time><time class="updated" datetime="2019-12-30T17:06:13-06:00">December 30, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="https://wpgu.com/i-fight-dragons-interview/" rel="bookmark" title="I Fight Dragons Interview">
                        <img width="348" height="215" src="https://wpgu.com/wp-content/uploads/2019/12/IMG_20191221_174156-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="https://wpgu.com/i-fight-dragons-interview/" rel="bookmark" title="I Fight Dragons Interview">
                            I Fight Dragons Interview                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-12-23T12:00:56-06:00">December 23, 2019</time><time class="updated" datetime="2019-12-22T21:24:08-06:00">December 22, 2019</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="https://wpgu.com/chill-with-the-beatles/" rel="bookmark" title="Chill with the Beatles">
                        <img width="348" height="215" src="https://wpgu.com/wp-content/uploads/2019/12/tumblr_plcrogYVRi1v7lw0w_1280-348x215.jpg" class="attachment-hitmag-grid size-hitmag-grid wp-post-image" alt="" /><div class="ccfic"></div>                    </a>
                    <h3 class="post-title">
                        <a href="https://wpgu.com/chill-with-the-beatles/" rel="bookmark" title="Chill with the Beatles">
                            Chill with the Beatles                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2019-12-08T15:00:13-06:00">December 8, 2019</time><time class="updated" datetime="2019-12-07T18:55:07-06:00">December 7, 2019</time></p>
                </div>
            
            
    </div>
    </div>

    
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://wpgu.com/top-albums-of-the-decade/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous Article</span> <span class="post-title">Top Albums of the Decade</span></a></div></div>
	</nav><div class="hm-authorbox">

    <div class="hm-author-img">
        <img alt='' src='https://secure.gravatar.com/avatar/46de021ddcb03841dd5331878e92f0b8?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/46de021ddcb03841dd5331878e92f0b8?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />    </div>

    <div class="hm-author-content">
        <h4 class="author-name">About WPGU Music Staff</h4>
        <p class="author-description">We're a gang of music lovers.</p>
        <a class="author-posts-link" href="https://wpgu.com/author/wpgu-music-staff/" title="WPGU Music Staff">
            View all posts by WPGU Music Staff &rarr;        </a>
    </div>

</div>
		</main><!-- #main -->
	</div><!-- #primary -->

	</div><!-- .hm-container -->
	</div><!-- #content -->

	
	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="hm-container">

			
			<div class="footer-widget-area">
				<div class="footer-sidebar" role="complementary">
											
									</div><!-- .footer-sidebar -->
		
				<div class="footer-sidebar" role="complementary">
					<aside id="custom_html-15" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://apps.apple.com/us/app/wpgu-107-1fm/id1474003578?mt=8" style="display:inline-block;overflow:hidden;background:url(https://linkmaker.itunes.apple.com/en-us/badge-lrg.svg?releaseDate=2019-07-26&kind=iossoftware&bubble=ios_apps) no-repeat;width:135px;height:40px;"></a>





</div></aside><aside id="custom_html-14" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">Apple, the Apple logo, iPhone, and iPad are trademarks of Apple Inc., registered in the U.S. and other countries and regions. App Store is a service mark of Apple Inc.

</div></aside>				</div><!-- .footer-sidebar -->		

				<div class="footer-sidebar" role="complementary">
					<aside id="custom_html-17" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://play.google.com/store/apps/details?id=com.wpgufm.player&pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1">
  <img alt="Get it on Google Play"
       src="https://developer.android.com/images/brand/en_generic_rgb_wo_45.png" />
</a></div></aside><aside id="text-18" class="widget widget_text">			<div class="textwidget"><p>Google Play and the Google Play logo are trademarks of Google LLC.</p>
</div>
		</aside>				</div><!-- .footer-sidebar -->			
			</div><!-- .footer-widget-area -->

			
		</div><!-- .hm-container -->

		<div class="site-info">
			<div class="hm-container">
				<div class="site-info-owner">
					Copyright &#169; 2020 <a href="https://wpgu.com/" title="WPGU 107.1" >WPGU 107.1</a>.				</div>			
				<div class="site-info-designer">
					Powered by <a href="https://wordpress.org" target="_blank" title="WordPress">WordPress</a> and <a href="https://themezhut.com/themes/hitmag/" target="_blank" title="HitMag WordPress Theme">HitMag</a>.				</div>
			</div><!-- .hm-container -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

	
</div><!-- #page -->


<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','music','the-top-50-albums-and-eps-of-2019','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["music","the-top-50-albums-and-eps-of-2019","post"],"url":"the-top-50-albums-and-eps-of-2019"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script><script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/jquery.flexslider-min.js?ver=62da2895fa89406029318a061f41db85'></script>
<script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/scripts.js?ver=62da2895fa89406029318a061f41db85'></script>
<script type='text/javascript' src='https://wpgu.com/wp-content/themes/hitmag/js/jquery.magnific-popup.min.js?ver=62da2895fa89406029318a061f41db85'></script>
<script type='text/javascript' src='https://wpgu.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.1.2'></script>
<script type='text/javascript' src='https://wpgu.com/wp-includes/js/wp-embed.min.js?ver=62da2895fa89406029318a061f41db85'></script>
</body>
</html>